Get in touch
Back
Downtime

Shit's down

Started 3 Jun at 06:00pm BST, resolved 4 Jun at 12:00am BST.

games.directory games.directory PlayStation Network Steam Xbox Live Call of Duty Valorant
Resolved

We have successfully rolled back to a previous deployment, which was working, and everything should be back to normal.

Posted 4 Jun at 12:00am BST.
Created

We're currently experiencing some issues with our deploying infrastructure.
One of our deploys managed to break our main server. We will start rolling back to a previous version.
We apologise for the inconvenience.

Posted 3 Jun at 06:00pm BST.