Get in touch
Back
Maintenance

Database Optimization Maintenance

Completed 27 Aug at 12:00am BST.

games.directory
Completed

Posted 27 Aug at 12:00am BST.
Started

games.directory will start performing some maintenance tasks on our database.
During this time, we expect some degraded performance but all of our services should be fully operational.

Posted 23 Aug at 12:00pm BST.